Quantcast

Page 1 of 2 12 LastLast
Results 1 to 15 of 28

Thread: 32X & Mega Everdrive?

  1. #1
    Man in Black Master of Shinobi IrishNinja's Avatar
    Join Date
    Nov 2013
    Location
    Vice City
    Posts
    2,168
    Rep Power
    50

    32X 32X & Mega Everdrive?

    so yeah, im getting blue screens, even though said 32X works just fine with Genesis/its own carts. Model 1 (non TMSS) Genny & Sega-CD plugged in, no idea what the issue is but over on khzz forums there's a few threads that say to try another 32X, which isn't really helpful. any ideas?

    also, my video cord between the two went to crap (loses colors a lot, im thinking pins might be bent or something) so i gotta go find another one of those!


  2. #2
    Mega Driven Raging in the Streets cleeg's Avatar
    Join Date
    Oct 2010
    Location
    Outer Space 2
    Age
    40
    Posts
    3,173
    Rep Power
    61

    Default

    Are your 32X titles in dot 32X format? Or dot bin? I believe it should be the former. I know this is probably something you're aware of already, but it's the first thing that comes to mind. Hope you get it sorted.

  3. #3
    Man in Black Master of Shinobi IrishNinja's Avatar
    Join Date
    Nov 2013
    Location
    Vice City
    Posts
    2,168
    Rep Power
    50

    Default

    hmm...i wanna say .32X? either way, the everdrive itself is booting to a blue screen, so i can't access the menus anyway. which again is odd, since when i switch over to the Genesis SCART/RGB, it works perfectly fine.


  4. #4
    Mega Driven Raging in the Streets cleeg's Avatar
    Join Date
    Oct 2010
    Location
    Outer Space 2
    Age
    40
    Posts
    3,173
    Rep Power
    61

    Default

    Try booting to that blue screen and starting a game to which you know you can navigate blindly, and see if you can get sound. At least then you'll have a clue as to whether your cables / 32X are affected.

  5. #5
    WCPO Agent roadkill's Avatar
    Join Date
    Apr 2014
    Location
    Pennsylvania, USA
    Age
    31
    Posts
    902
    Rep Power
    15

    Default

    Quote Originally Posted by IrishNinja View Post
    also, my video cord between the two went to crap (loses colors a lot, im thinking pins might be bent or something) so i gotta go find another one of those!
    Are you using the official Sega patch cables? I have the same problem with mine and it shows a purple color on white text. However when I use an aftermarket gold plated model 2 patch cable along with the official model 1 breakaway patch cable, it fixes the problem for some reason.

  6. #6
    Man in Black Master of Shinobi IrishNinja's Avatar
    Join Date
    Nov 2013
    Location
    Vice City
    Posts
    2,168
    Rep Power
    50

    Default

    ah yeah, i just picked up a gold plated after market one too from ebay, thanks!

    just wondering if anyone knows anything about why mega everdrives work on some 32X's but not others?


  7. #7
    Raging in the Streets xelement5x's Avatar
    Join Date
    Feb 2011
    Location
    Southwest USA
    Age
    39
    Posts
    4,308
    Rep Power
    70

    Default

    Quote Originally Posted by IrishNinja View Post
    ah yeah, i just picked up a gold plated after market one too from ebay, thanks!

    just wondering if anyone knows anything about why mega everdrives work on some 32X's but not others?
    32X was notorious for being finicky, the first revision has cart issues from my experience where some games just don't like to play, I think it is based on the cart tension. Also, I have a MegaED and it works fine with my 32X and setup.
    Quote Originally Posted by StarMist View Post
    A spine card is the hymen of a new game assuring its first owner that he is truly her one and only, and of a used game assuring its new owner that whilst she has been played with in the past that play has never been too careless or thorough.

  8. #8
    WCPO Agent roadkill's Avatar
    Join Date
    Apr 2014
    Location
    Pennsylvania, USA
    Age
    31
    Posts
    902
    Rep Power
    15

    Default

    Quote Originally Posted by IrishNinja View Post
    just wondering if anyone knows anything about why mega everdrives work on some 32X's but not others?
    Quote Originally Posted by xelement5x View Post
    32X was notorious for being finicky, the first revision has cart issues from my experience where some games just don't like to play, I think it is based on the cart tension. Also, I have a MegaED and it works fine with my 32X and setup.
    Was the 32X expansion port dongle supposed to fix those kind of issues?



    I have two of these but I've never needed to use them on any Genesis revision I've come across so far.

  9. #9
    Raging in the Streets xelement5x's Avatar
    Join Date
    Feb 2011
    Location
    Southwest USA
    Age
    39
    Posts
    4,308
    Rep Power
    70

    Default

    Quote Originally Posted by roadkill View Post
    Was the 32X expansion port dongle supposed to fix those kind of issues?



    I have two of these but I've never needed to use them on any Genesis revision I've come across so far.
    That is part of it, but if you've got a SegaCD connected it does the same thing as that bus terminator. From my anecdotal experience it has something to do with PCB thickness on some games. I could get copies of Chaotix playing if I was very specific about the amount I would insert the cart, or insert it all the way and pull it slightly back out. YMMV, it could also be those ribbons inside the unit, but I've never personally needed to reseat those.
    Quote Originally Posted by StarMist View Post
    A spine card is the hymen of a new game assuring its first owner that he is truly her one and only, and of a used game assuring its new owner that whilst she has been played with in the past that play has never been too careless or thorough.

  10. #10
    Man in Black Master of Shinobi IrishNinja's Avatar
    Join Date
    Nov 2013
    Location
    Vice City
    Posts
    2,168
    Rep Power
    50

    Default

    see, i cleaned/reset the ribbons when i got it second-hand and every game ive thrown at it worked, at least 32X titles...but not the mega =/


  11. #11
    Hero of Algol
    Join Date
    Aug 2010
    Posts
    7,703
    Rep Power
    174

    Default

    Quote Originally Posted by IrishNinja View Post
    see, i cleaned/reset the ribbons when i got it second-hand and every game ive thrown at it worked, at least 32X titles...but not the mega =/
    Which PSU are you using?
    The Mega ED consumes a lot more power than a regular cart. Blue screens are probably caused by memory errors which, maybe, are being caused by iffy/insuficient power supply.

  12. #12
    Man in Black Master of Shinobi IrishNinja's Avatar
    Join Date
    Nov 2013
    Location
    Vice City
    Posts
    2,168
    Rep Power
    50

    Default

    Ah! hadn't though of that...I'm using the Trio, which i understand is supposed to be sufficient for normal power draws anyway, and i'm pretty sure i have it hooked in right (i wanna say the plugs only fit the correct slots anyway, except the Sega CD one that's labeled). could it be that said trio's not giving the 32X enough for that combination?


  13. #13
    Hero of Algol
    Join Date
    Aug 2010
    Posts
    7,703
    Rep Power
    174

    Default

    Quote Originally Posted by IrishNinja View Post
    Ah! hadn't though of that...I'm using the Trio, which i understand is supposed to be sufficient for normal power draws anyway, and i'm pretty sure i have it hooked in right (i wanna say the plugs only fit the correct slots anyway, except the Sega CD one that's labeled). could it be that said trio's not giving the 32X enough for that combination?
    I don't wanna state or promise anything as the Mega ED power consumption shouldn't be significant to such PSU but, you know, if everything was working as supposed you wouldn't be getting those blue screens.
    So I'd definitely try to boot the 32X using a separate PSU for it, even if just to be able to take this variable out of the equation in case it doesn't solve the problem.
    Last edited by Barone; 03-11-2015 at 06:23 PM.

  14. #14
    Raging in the Streets xelement5x's Avatar
    Join Date
    Feb 2011
    Location
    Southwest USA
    Age
    39
    Posts
    4,308
    Rep Power
    70

    Default

    Quote Originally Posted by Barone View Post
    I don't wanna state or promise anything as the Mega ED power consumption shouldn't be significant to such PSU but, you know, if everything was working as supposed you wouldn't be getting those blue screens.
    So I'd definitely try to boot the 32X using a separate PSU for it, even if just to be able to take this variable out of the equation in case it doesn't solve the problem.
    Great observation! I'll be intrigued to see if this is the cause.
    Quote Originally Posted by StarMist View Post
    A spine card is the hymen of a new game assuring its first owner that he is truly her one and only, and of a used game assuring its new owner that whilst she has been played with in the past that play has never been too careless or thorough.

  15. #15
    The Best Genesis Master of Shinobi GohanX's Avatar
    Join Date
    Oct 2007
    Age
    40
    Posts
    2,153
    Rep Power
    39

    Default

    I can't be much help, but I have used both the V3 Everdrive and the Mega Everdrive with a 32x before, both with separate power supplies and a Trio. The Mega still works fine after Neptunizing my model 2 as well.
    Quote Originally Posted by CMA Death Adder
    Recently I sold the majority of my 32X games for a measly 18 bucks. With it, I bought some tacos. Definitely a more pleasing choice.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •