Quantcast

Results 1 to 4 of 4

Thread: PAL Dreamcast no video no audio

  1. #1
    Road Rasher
    Join Date
    May 2015
    Location
    East Coast AUSTRALIA
    Posts
    446
    Rep Power
    7

    Dc PAL Dreamcast no video no audio

    Hi all,

    I have a PAL Dreamcast that last time i used it everything worked ok, but would very rarely reset without warning.

    I have tested the power supply, 3.35v, 5.03v, and almost 13v, so it is fine, tested on the console pins, not direct into the power supply.

    Fan is spotless and runs perfect.

    Mainboard is spotless and does not have damage from screws, all solder joints that are visible look and test perfectly.

    A/V cord is fine, and VGA cord is fine, theyre firmly inserted and making good clean contact.

    Battery is dead flat and wont hold charge, but it never did before and it all worked.

    When i turned it on 2 days ago i would occationally get sync on the TV, black screen, nothing else, but more often than not id just get nothing, no signal at all, but you do see a flash as you shut it off. Now it doesnt ever sync at all.

    GD-ROM drive is fine and works.

    The console spins the disc and sounds like it is trying to load it, but after 2-3 minutes it stops.

    The VMU comes on when the console is turned on.

    The power LED comes on bright the instant you hit the switch.

    There is no sound at all, and no video either.


    This seems to be a pretty common issue, but all threads seem to get to the end with no fix, just a heap of people saying its the power supply, its the A/V port, its the cables, its the GD-ROM, its the video DAC, but its not those things.

    Something on the mobo is causing this issue.

    Who knows what is doing this?

  2. #2
    Hedgehog-in-Training Hedgehog-in-TrainingSports Talker troopa jr's Avatar
    Join Date
    Dec 2018
    Location
    Burgos, Spain
    Posts
    39
    Rep Power
    0

    Default

    If there is no gdrom unit or ventilator, the dreamcast does not start. But if the vmu is working, this may be not the case... I was just going to suggest you to check the video wire or the video connector are making good contact, but you seem to have tryed everything......

  3. #3
    Road Rasher
    Join Date
    May 2015
    Location
    East Coast AUSTRALIA
    Posts
    446
    Rep Power
    7

    Default

    Quote Originally Posted by troopa jr View Post
    If there is no gdrom unit or ventilator, the dreamcast does not start. But if the vmu is working, this may be not the case... I was just going to suggest you to check the video wire or the video connector are making good contact, but you seem to have tryed everything......
    As i said yes, this is not the cable, its not the fan, and its not the GD-ROM, the unit is complete when being tested.

  4. #4
    Road Rasher
    Join Date
    May 2015
    Location
    East Coast AUSTRALIA
    Posts
    446
    Rep Power
    7

    Default

    Still no further with this, has anyone else found theyre stuck with?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •