Quantcast

Results 1 to 5 of 5

Thread: mega cd 1 play cd audio but no games

  1. #1
    Wildside Expert
    Join Date
    Mar 2013
    Posts
    186
    Rep Power
    7

    Default mega cd 1 play cd audio but no games

    please help me. i was playing fine, lens is in 100% perfect condition, i use it with a jap not modded md2.
    but when i tried to put a mega drive 1 pal modded on it (that i discovered have bad switches and not boot cart games or boot loop the mega everdrive), i discovered that when i put again the md jap the mega cd read only cd audio, when i insert any game instead of displaying press start i see the access red led change from normal blinking to fast blinking, what does it mean? how i can fix it? IS NOT THE LENS!
    Last edited by Arnold101; 03-13-2019 at 10:23 AM.

  2. #2
    Wildside Expert
    Join Date
    Mar 2013
    Posts
    186
    Rep Power
    7

    Default

    hey too many replies.

  3. #3
    VA1LT CHIP ENABLED Master of Shinobi OverDrone's Avatar
    Join Date
    Jun 2012
    Posts
    1,560
    Rep Power
    45

    Default

    I would start the investigation by cleaning the connectors in both MD's expansion ports, as well as the MCD2's pins. Then try re-seating the JP MD with the MCD2 and try to boot a game.

    Are you using burnt CDRs or original discs?

  4. #4
    Wildside Expert
    Join Date
    Mar 2013
    Posts
    186
    Rep Power
    7

    Default

    Quote Originally Posted by OverDrone View Post
    I would start the investigation by cleaning the connectors in both MD's expansion ports, as well as the MCD2's pins. Then try re-seating the JP MD with the MCD2 and try to boot a game.

    Are you using burnt CDRs or original discs?
    hi, original disc, i swapped out all pcb and drives and ribbon cables on my cpu board and the problem come from here, the error is still present. it's surely corrosion problem. it' a mcd1 jap.


    close please i fixed it
    Last edited by Arnold101; 03-20-2019 at 07:39 PM.

  5. #5
    Raging in the Streets xelement5x's Avatar
    Join Date
    Feb 2011
    Location
    Southwest USA
    Age
    39
    Posts
    4,290
    Rep Power
    69

    Default

    Quote Originally Posted by Arnold101 View Post
    hi, original disc, i swapped out all pcb and drives and ribbon cables on my cpu board and the problem come from here, the error is still present. it's surely corrosion problem. it' a mcd1 jap.


    close please i fixed it
    Well how did you fix it?
    Quote Originally Posted by StarMist View Post
    A spine card is the hymen of a new game assuring its first owner that he is truly her one and only, and of a used game assuring its new owner that whilst she has been played with in the past that play has never been too careless or thorough.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •