Quantcast

Results 1 to 2 of 2

Thread: SMS Model 2 - Player One always moving Left

  1. #1
    Outrunner thesegadude's Avatar
    Join Date
    Jun 2011
    Location
    Canada
    Posts
    606
    Rep Power
    25

    Default SMS Model 2 - Player One always moving Left

    Hi Guys,

    I have a model 1 SMS and the player one port is always sending the signal to move left. 100% on, all the time.

    I've tried several known working SMS control pads and I've even re-soldered the pins on the Player One port. No change.

    What else do you think I can look at?

    Thanks!

  2. #2
    Wildside Expert fluxcore's Avatar
    Join Date
    Aug 2013
    Posts
    240
    Rep Power
    8

    Default

    I had an SMS2 with exactly the same symptom on alex kidd, some other games with different priority showed that other inputs were stuck on as well (down and right).

    Turned out the 315-5237 chip had become faulty. Replacing the chip is probably the best way to proceed, if yours is the same.

    I do know a guy who took it upon himself as a challenge to fix the console without replacing the chip, he had to lift the associated pins, and programmed an additional GAL with the logic needed to take the inputs and dump the data onto the data bus. I very much doubt there are many other people around that could be bothered doing that, even if they could work out how.

    Realistically, the SMS2 is not worth fixing, unless you can find another faulty unit with some other issue.

    Now I read your post more carefully, your title says 'model 2' but the body says 'model 1', but it's still quite likely to be a similar problem. Not sure if the SMS1 has more discrete chips in this area that might make a repair more plausible.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •