View Full Version : Strange issue with Daytona USA CCE and its save files

02-20-2019, 11:17 AM
I have a Daytona USA CE (jap) and a Daytona USA CCE (pal) and wanted to test if both work with the same save file (most games don't but some few like X-Men COTA do - both jap and pal share the same save file).

So I had a save file of the japanese game on my memory cart and wanted to play the pal gane but it always freezes at the Daytona trademark screen. Not even reset or to open the cd lid changed it. I could only switch off the console. I tried it a few times and thought my game is screwed but then I tried it with another memory xart WITHOUT a japanese Daytona file and the game worked fantastic.

Now I tried the opposite. I booted the japanese game with a save file of the pal one and here it automatically deleted my savefile. The memory cart was full of different files but the Daytona one was missing afterwards.

Strange strange.....

02-20-2019, 11:57 PM
Do note that the Japanese version of Daytona USA CE is a much later revision, identical to the US Daytona USA CCE Netlink Edition. So it's possible they noticed that bug and fixed it - the game got many other fixes too.

I hate it when games delete each others saves. It took me months to figure out that the USA and PAL versions of Scorcher mutually destroy each others saves.

04-03-2019, 12:17 PM
never noticed saturn games possibly destroying each others files
but i have had uh ..other saturn misadventures