Quantcast

Results 1 to 11 of 11

Thread: Virtua Racing SVP Cart Dead?

  1. #1
    Retro Nutter! Road Rasher Speedle's Avatar
    Join Date
    Mar 2009
    Location
    UK
    Age
    37
    Posts
    383
    Rep Power
    13

    Default Virtua Racing SVP Cart Dead?

    Hey Guys,

    I picked up a lovely mint copy of Virtua Racing this week, only to take it home and find it's not loading.

    I get the Licensed by Sega screen then nothing but a black screen.

    I've tested this on both Model 1 MD's that I have and both yield the same results

    I opened the cart and gave it a good clean with contact cleaner and also replaced both the caps... alas still not booting.

    Has anyone else had this issue with VR? I've searched High and Low on the interwebs and the forums and come up with nothing apart from a few others having similar issues with no resolution.

    I'm resigned to the fact it may be dead...

  2. #2
    Raging in the Streets Thierry Henry's Avatar
    Join Date
    Dec 2008
    Location
    SA
    Posts
    3,176
    Rep Power
    97

    Default

    My JP VR always hangs/freezes at the exact same spot every time.
    As with yourself, I've also not been able to find any relevant info as to a possible fix.



    Quote Originally Posted by soviet View Post
    We believe! SEGA Empire will live again! As the Jews re-established their Israel, GOD will never forget his people, SEGA will never forget her fans!

  3. #3
    Retro Nutter! Road Rasher Speedle's Avatar
    Join Date
    Mar 2009
    Location
    UK
    Age
    37
    Posts
    383
    Rep Power
    13

    Default

    Damn that sucks dude!

    I did re-flow all the SVP chip soldier as well to no effect, may reflow the entire board and see if that helps...

  4. #4
    Creator of the Mega Amp Raging in the Streets Ace's Avatar
    Join Date
    Jun 2008
    Location
    Montreal, QC, Canada
    Age
    29
    Posts
    3,737
    Rep Power
    43

    Default

    Just to be sure, you should measure the voltage on the 5V pins. In my experience, Virtua Racing tends to freak out when you have voltage on the cartridge slot below approximately 3.9V. Also, this game does not behave well on overclocked consoles at all.
    HATES ATGAMES WITH A PASSION


    Mega Amp: An all-new audio circuit for your Sega Genesis/MegaDrive and clones.

    Note: If you want to contact me on Skype, identify yourself or your contact request will be rejected.

  5. #5
    feel the shell shock! WCPO Agent negative chill's Avatar
    Join Date
    Nov 2012
    Location
    Mobile, Alabama
    Age
    30
    Posts
    912
    Rep Power
    23

    Default

    Kind of an interesting issue, wonder if any owners of 32x carts have had a similar problem or if it's just exclusive to VR for the Genesis

    “The Internet is the first thing that humanity has built that humanity doesn’t understand, the largest experiment in anarchy that we have ever had.”—Eric Schmidt

  6. #6
    Retro Nutter! Road Rasher Speedle's Avatar
    Join Date
    Mar 2009
    Location
    UK
    Age
    37
    Posts
    383
    Rep Power
    13

    Default

    so far it seem the SVP versions are the only one's where I've found others having issues. I know the SVP cart apparently doesn't like being plugged into a 32x and wont work like this. It's probably something to do with the fact that Sega rushed it into production as an answer to Nintendo's Super FX chip. As result maybe the components used are slightly sub-standard... who knows.

    Anyway's I bought myself a cart only copy from eBay which works so at least I have a working CIB copy now, so I can experiment with the broken copy now and see if I can get it working again. Should I have any luck I will let you all know.

    Had a play though on it and it's actually not as bad as many people say. Runs fast and smooth, yeah it's not as good as the 32x version but it's totally playable IMO. I like it anyways

  7. #7
    Raging in the Streets Thierry Henry's Avatar
    Join Date
    Dec 2008
    Location
    SA
    Posts
    3,176
    Rep Power
    97

    Default

    Well this is my faulty VR that I had taken a pic of a few years ago when I posted it on these boards.

    If your trained eye can pick up something there, let me know.



    Quote Originally Posted by soviet View Post
    We believe! SEGA Empire will live again! As the Jews re-established their Israel, GOD will never forget his people, SEGA will never forget her fans!

  8. #8
    Mega Driven Raging in the Streets cleeg's Avatar
    Join Date
    Oct 2010
    Location
    Outer Space 2
    Age
    40
    Posts
    3,194
    Rep Power
    61

    Default

    I agree, it's very playable and totally impressive that such an 'experimental' release plays as well as it does. Also, I like the plain polygon style in general so this game looks nice to me. I get why it looks ugly to others though.

    Glad you got a working copy!

  9. #9
    Hedgehog-in-Training Hedgehog-in-Training
    Join Date
    Nov 2019
    Posts
    18
    Rep Power
    0

    Default

    Same here. Had the game always in its box.

    Want to start up. It starts up with the SEGA logo, then goes into the intro screen but video is all distorted! Audio is good so chip dead?

    Any way i can test something?

  10. #10
    Hedgehog-in-Training Hedgehog-in-Training
    Join Date
    Nov 2019
    Posts
    18
    Rep Power
    0

    Default

    You mean C21 and C22? @Ace

  11. #11
    Hedgehog-in-Training Hedgehog-in-Training
    Join Date
    Nov 2019
    Posts
    18
    Rep Power
    0

    Default

    I had this game for years and years on the shelf, played perfectly, now suddenly all video graphics distortions, corrupted.

    It boots up , and video is all distorted. Audio is fine.

    Any idea what is causing this? How can i repair this?

    I replaced the 2 caps already.

    Dead chip(s)?

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (1 members and 1 guests)

  1. SPiET

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •