Quantcast

Results 1 to 9 of 9

Thread: Mark III Light Phaser Compatibility?

  1. #1
    Benjamin's Avatar
    Join Date
    Jun 2006
    Location
    New Orleans, LA
    Age
    43
    Posts
    1,585
    Rep Power
    33

    Master System Mark III Light Phaser Compatibility?

    I understand that the Light Phaser was not released in Japan, but I'm wondering if the gun would at least still be compatible with a Mark III running an NTSC game. I know light gun information is processed by the peripheral itself, so I would like to think it would still work... but I'd like to know if anyone has details on this before going down that path.

  2. #2
    urusei yatsura Master of Shinobi lumclaw's Avatar
    Join Date
    Jul 2010
    Posts
    1,362
    Rep Power
    17

    Default

    As far as I can tell, Light Phaser is incompatible with the Japanese system region setting. Including when used on a Genesis / Mega Drive.
    http://www.sega-16.com/forum/showthr...Phaser-problem

  3. #3
    Done with Sega-16 (sorta) Master of Shinobi
    Join Date
    Apr 2007
    Location
    San Jose, CA
    Age
    30
    Posts
    1,636
    Rep Power
    26

    Default

    The Mark III doesn't work with the Light Phaser since it doesn't even have the TH signal needed for the light sensor. The Japanese SMS seems to have the proper signal so it might work? I recently ordered a Light Phaser so I'll have to check this out...

  4. #4
    urusei yatsura Master of Shinobi lumclaw's Avatar
    Join Date
    Jul 2010
    Posts
    1,362
    Rep Power
    17

    Default

    Quote Originally Posted by ApolloBoy View Post
    The Mark III doesn't work with the Light Phaser since it doesn't even have the TH signal needed for the light sensor. The Japanese SMS seems to have the proper signal so it might work? I recently ordered a Light Phaser so I'll have to check this out...
    That sounds odd but I'm stumped if it's true. Why would the Japanese SMS have it, but not the Japanese Megadrive?

  5. #5
    Hedgehog-in-Training Hedgehog-in-Training
    Join Date
    Oct 2016
    Location
    SeaTac, WA, USA
    Posts
    9
    Rep Power
    0

    Default

    This is strange I have two of the light phasers and neither one worked very well on my J-SMS. I should retry it and see and see if I get different results with my x'eye. I want to say it did work when I turned the brightness way up, making me suspect they photo-diodes just needed to be replaced.

  6. #6
    urusei yatsura Master of Shinobi lumclaw's Avatar
    Join Date
    Jul 2010
    Posts
    1,362
    Rep Power
    17

    Default

    Quote Originally Posted by haightc View Post
    This is strange I have two of the light phasers and neither one worked very well on my J-SMS. I should retry it and see and see if I get different results with my x'eye. I want to say it did work when I turned the brightness way up, making me suspect they photo-diodes just needed to be replaced.
    It should be fine. the x'eye doesn't use japanese region.

  7. #7
    Done with Sega-16 (sorta) Master of Shinobi
    Join Date
    Apr 2007
    Location
    San Jose, CA
    Age
    30
    Posts
    1,636
    Rep Power
    26

    Default

    EDIT: Wow the Light Phaser actually works on the Japanese SMS!
    Last edited by ApolloBoy; 09-13-2017 at 07:15 PM.

  8. #8
    Hedgehog-in-Training Hedgehog-in-Training
    Join Date
    Oct 2016
    Location
    SeaTac, WA, USA
    Posts
    9
    Rep Power
    0

    Default

    Quote Originally Posted by ApolloBoy View Post
    EDIT: Wow the Light Phaser actually works on the Japanese SMS!
    I tried again on my J-SMS and the light gun for me does work as well, I have to turn the brightness and contrast all the way up.
    I was going to try on my x'eye but then I remembered I don't have a powerbase converter and my mega everdrive X7 doesn't let me play master system games.

    Does anyone happen to know a good replacement for the photodiode?

  9. #9
    Hedgehog-in-Training Hedgehog-in-Training
    Join Date
    Oct 2016
    Location
    SeaTac, WA, USA
    Posts
    9
    Rep Power
    0

    Default

    Also to confirm, I did have a Genesis to Mark III adapter and light guns work the same as on the J-SMS. So in my case, I feel pretty confident I need to replace the sensors on my light guns. It is strange that according to SMS power's document it's shouldn't work, perhaps because I am using a master everdrive with US to mark III adapter.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •