Quantcast

Results 1 to 5 of 5

Thread: Saturn randomly died

  1. #1
    Wildside Expert Legend77's Avatar
    Join Date
    Dec 2014
    Posts
    157
    Rep Power
    8

    Default Saturn randomly died

    I had a few consoles hooked up to an area. I decided to move them just a little bit to another area that is more spacious. My other systems are fine...the Saturn refuses to work now. IF it reads the disc at start up then it takes a very long time to load. Should it reach gameplay, it'll play for about 30 seconds then freeze entirely. I have been playing it here and there the past couple weeks. It never showed signs. As soon as I move it it just stops. I don't understand what happened at all. Any suggestions? I've reinserted my memory cart. I cleaned the laser. Nothing. The issue started as the sound messing up. Then the other problems came about. Makes no sense to me.
    I am Mr_32X

  2. #2
    Mega Driven Raging in the Streets cleeg's Avatar
    Join Date
    Oct 2010
    Location
    Outer Space 2
    Age
    41
    Posts
    3,217
    Rep Power
    66

    Default

    Is there any known issue with corrosion of parts / caps leaking causing shorts etc..?

  3. #3
    Wildside Expert Legend77's Avatar
    Join Date
    Dec 2014
    Posts
    157
    Rep Power
    8

    Default

    In all the years I've owned it....zero issues. Thats why I am weirded out by this. I moved it less than 5 feet to a new area so it didn't travel far. I unplugged it, replugged it, and this. I have rechecked the cables a few times too just to make sure.
    I am Mr_32X

  4. #4
    Comrade as in friend. Master of Shinobi ComradeOj's Avatar
    Join Date
    Dec 2012
    Location
    New Mexico, USA
    Age
    25
    Posts
    1,379
    Rep Power
    60

    Default

    Quote Originally Posted by Legend77 View Post
    I have rechecked the cables a few times too just to make sure.
    Do you mean the TV/Power hoockups, or the internal ribbon cables?

    IIRC, there are a few ribbon cables inside the system. Maybe a combination of age and slight movement was enough to make one of the connections unreliable. I would take apart the system, and re-seat all internal cables if you are able. I know the 32X can sometimes have issues due to the ribbon cables inside it coming slightly loose. Maybe the saturn is the same way?
    Modded consoles:
    Master System (v7040) with s-video & direct AV out
    Model 1 with 10mhz overclock & halt switches
    Model 1 with 10mhz 68010
    Model 2 VA2.3 with unfiltered Mega Amp, & s-video
    Model 3 VA1 with compatibility fixes & s-video
    32X with s-video
    Visit my web site at www.mode5.net
    Or my collection of homebrew Genesis games, programs, and music on SEGA-16!

  5. #5
    Wildside Expert Legend77's Avatar
    Join Date
    Dec 2014
    Posts
    157
    Rep Power
    8

    Default

    Yes I meant the av and power cable. I considered opening it up but wasn't sure what I should look for. I will have to check that but I was so agitated that I unhooked it and put it up. Sounds silly maybe but after lots of Sotn gameplay then this I got irritated.
    I am Mr_32X

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •