Quantcast

Results 1 to 12 of 12

Thread: Everdrive pro problem or megadrive problem?

  1. #1

    Join Date
    Oct 2013
    Posts
    10
    Rep Power
    0

    Default Everdrive pro problem or megadrive problem?

    Go easy on me please!

    So I bought myself a mega drive (had to wait a age for a cable to connect it to a HDTV) and eventually got a everdrive. At first it was working great THEN......................

    (Hope this works)

    https://onedrive.live.com/?authkey=%...214735&o=OneUp

    So does anyone know if that is a cartridge or a megadrive issue?

  2. #2
    Hero of Algol
    Join Date
    Aug 2010
    Posts
    8,306
    Rep Power
    199

    Default

    Since you say it used to work properly and by the video it's glitching without you even change the directory, I'd say probably the Everdrive is faulty now.


    HDTV

  3. #3
    WCPO Agent CrossBow's Avatar
    Join Date
    Feb 2017
    Location
    Ivory Tower Collections
    Posts
    889
    Rep Power
    17

    Default

    When the screen is glitched up like that, if you slightly touch the cart to press it lightly back or towards you while in the slot, does it change the graphics in the process?

  4. #4
    The Cat in the Hat Shining Hero NeoVamp's Avatar
    Join Date
    Nov 2008
    Posts
    10,682
    Rep Power
    207

    Default

    Could be that your Mega Drive cart slot is dirty, try cleaning it. (and if its dirty clean the everdrive connectors too)
    if it still happens then at least you know its not that.

  5. #5

    Join Date
    Oct 2013
    Posts
    10
    Rep Power
    0

    Default

    The head possibly in the cartridge seems to be the same thing i'm getting told. I gonna try get some cleaning material see if I can go from there. Initially the everdrive worked. Was able to get into the roms/bios all fine then just went mental on me and now at the moment I don't even get the sega bios screen when putting it in the mega drive so something is amiss somewhere

  6. #6
    WCPO Agent CrossBow's Avatar
    Join Date
    Feb 2017
    Location
    Ivory Tower Collections
    Posts
    889
    Rep Power
    17

    Default

    This is why I was asking if the glitching changed based on wiggle of the cart slightly. When it does it means the cart isn't making a good connection with the cartridge slot pins and you will get corrupted graphics and also a black screen condition as well.

  7. #7

    Join Date
    Oct 2013
    Posts
    10
    Rep Power
    0

    Default

    OK wiggling has done nothing. It as if it wants to boot into the bios? (should model 1 mega drives have a bios built in)? but wiggling wasn't even getting me to the BIOS screen so what I am gonna do I am gonna send the cart back to where I got it from erm and I should hopefully have a mega drive cart to test it for sure. I'm convinced i'll get it fixed but not sure at what cost. It is weird though as I said initially my everdrive was going great guns then it seemed to be as soon as I tried to change a theme it froze and then started to go awkward with the glitches as I showed on the video

  8. #8
    Hedgehog-in-Training Hedgehog-in-TrainingOutrunner
    Join Date
    Sep 2016
    Posts
    603
    Rep Power
    18

    Default

    Before sending the ED back, buy some 2$ sports game to test the console.

  9. #9

    Join Date
    Oct 2013
    Posts
    10
    Rep Power
    0

    Default

    So I did promise I was gonna get a couple of megadrive games to test the machine. I got a couple and low and behold................the system refusing to load any of them so I now know it's the mega drive that's cream crackered

  10. #10

    Join Date
    Oct 2013
    Posts
    10
    Rep Power
    0

    Default

    OK so I have a replacement mega drive at the moment the cartridge slot seems to be working. Just need to be careful as it is delicate (crashes when you move a cartridge) got it at a reduced price and had a fiver left over so bought lion king as a test game. All appears to be working now just need to get my everdrive back and hopefully be good to go

  11. #11
    Hero of Algol
    Join Date
    Aug 2010
    Posts
    8,306
    Rep Power
    199

    Default

    Well, good to know that the Everdrive was probably not the one at fault then, 'cause that could affect a lot more people.

    Thanks for the updates.

  12. #12

    Join Date
    Oct 2013
    Posts
    10
    Rep Power
    0

    Default

    Everdrive back all fully A OK and that problem I thought might have been the cartridge slot again? was the lion king being delicate if you moved it but the everdrive *DROOL* all working. Now what to play out of 22 thousand plus roms....................

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •